Hartl Ruby on Rails Tutorial Rails version number issues

Hey all, I'm going through Michael Hartl's Ruby on Rails Tutorial 4th Edition and running into some issues. In the very beginning of the tutorial while setting up my work space, I'm working on putting the correct gem versions in to get up and running. Thing is it's stressed to use version 5.0.0 of rails to stay in line with the tutorial, but I keep ending up with version 5.0.6

I'm beyond brand new to coding of any sort so if you could help walk me through this, I'd greatly appreciate it. I even emailed and heard back from Hartl himself about this issue but his suggestions haven't fixed my issue. Here are some screenshots of my code and his suggestion as well. If you could help me out, I'd really appreciate it. Thanks for your time

View post on imgur.com

1 thought on “Hartl Ruby on Rails Tutorial Rails version number issues”

  1. Welcome to rails!! This is a good beginning journey into the technical sophistication that Hartl rails (heh) on!

    Real answer: check out this — https://github.com/rails/rails/issues/9979

    Basically, for Rails vX.Y.Z, any change to Z just means bugfixes. So 5.0.6 is totally okay to use!

    To actually answer your question: change the Rails line in your Gemfile (in your project directory) to `gem “rails”, “5.0.0”` and then run `bundle install` in terminal to update your project gems. But don’t do this! It’s okay to use 5.0.6 for reasons above. But now you know how Gemfile handles specifying gem versions. 🙂

    Don’t really worry about the Rails version installed on your system – the important thing is the Rails version in your Gemfile.

    Reply

Leave a Comment